Iam unable to run programs from command prompt, my environment variables are correct. When i type javac on command prompt ,it gives the correct data ie possible outputs. When i type java it again responds as it should. But if i run a program say:
java practice
then it gives java.lang.NoClassDefFound Error , it used to work perfectly fine before, but then i did some changes in bin folder, iam completely helpless tried almost everything, but still isnt working. When i point the same jdk in eclipse/netbeans it works fine
pl help

but then i did some changes in bin folder

what did you change in there, and what for?

i didnt change much as of such, only there were many .class files in it. i only deleted them but iam afraid that by mistake probably i deleted some other files also. but java file is still there

Remove this installation and replace it with new one, check your path etc. And remember in the future to not mess it with it, even if it suggest you should place library there (often example of old database connector tips)