I downloaded OpenCV last Wednesday and tried to link it with DevC++

I followed the instructions found here and I get the error

cannot find -lhighgui
ld returned 1 exit status


I'm sure the code that I tried to compile is working because I previously compiled and ran that code before I linked DevC++ to OpenCV

Next, I tried the instructions found here and I got this error instead

cannot find -lcxcore
ld returned 1 exit status


I dled another version of DevC++ with OpenCV 2.1 but it still doesn't work. Now I tried using OpenCV 2.0 but it still doesn't work

I noticed with the two versions of OpenCV that I tried that instead of being in an individual folder like this

OpenCV\cv\include

they're located inside an src folder

OpenCV2.0\src\cv

I don't know if it affects the linking process but it's weird because I dled them from the link found at the OpenCV wiki but it's installed differently.

Here are the screencaps from the DevC++ compiler (note: in this screencaps, I just thought of changing 'lcvcam' to 'lml' since I can't find a folder named 'cvcam' in OpenCV but it still didn't worked)

1
2
3
4
5

Now I'm running out of ideas to make OpenCV work with DevC++. Any help would be appreciated. Thanks.

I found the solution!

For anyone with similar problems as mine, just follow the instructions here

This question has already been answered. Start a new discussion instead.