Hi
I am trying to use axis with Tomcat. I am trying to execute AdminClient of axis. I am getting the following error. I get connection refused exception, i donot understand connection to where is refused :sad: Can anybody tell me where I am going wrong.
Thanks in advance
Srinivas

Exception: AxisFault
 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
 faultSubcode:
 faultString: java.net.ConnectException: Connection refused: connect
 faultActor:
 faultNode:
 faultDetail:
        {http://xml.apache.org/axis/}stackTrace:java.net.ConnectException: Connection refused: connect
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.PlainSocketImpl.doConnect(Unknown Source)
        at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
        at java.net.PlainSocketImpl.connect(Unknown Source)
        at java.net.SocksSocketImpl.connect(Unknown Source)
        at java.net.Socket.connect(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:153)
        at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:120)
        at org.apache.axis.transport.http.HTTPSender.getSocket(HTTPSender.java:191)
        at org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:404)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:138)
        at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2765)
        at org.apache.axis.client.Call.invoke(Call.java:2748)
        at org.apache.axis.client.Call.invoke(Call.java:1784)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:439)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:404)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:410)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:320)
        at org.apache.axis.client.AdminClient.main(AdminClient.java:463)

        {http://xml.apache.org/axis/}hostname:myipaddress

I guess the adminclient is trying to connect to the server you're trying to administrate but that server is either not running or you're behind a firewall which is blocking the request.

I've not used Axis but those are the main reasons for "connection refused" errors in general.

hi
I had solved it. I had to specify the port, since it was port 80 I thought it will be taken by default.

I was calling like this:
java org.apache.axis.client.AdminClient GavsWebservice.wsdd

I changed it to :
java org.apache.axis.client.AdminClient -p 80 <myservice>.wsdd

Now it works. I must have worked more on it before putting on the this forum. Sorry for the inconvienience.

Thanks a lot
Srinivas

Hi everyone,

Now it works. I must have worked more on it before putting on the this forum. Sorry for the inconvienience.

Don't worry about it. Everyone is here to learn

Richard West

\\\\\\\\\\\\//////

@cheenu78

Thanks. it works for me.
i was running tomcat at 9090 port. so i changed the command to

java org.apache.axis.client.AdminClient -p 9090 <myservice>.wsdd

This article has been dead for over six months. Start a new discussion instead.