0

hi,
I'm working on a an app that uses access database so.. while making the setup file i added the file in the application folder along with the .exe file that uses it..
but after installation the .exe file is not able to alter the database as the user is not given the permission to write the database file which installer stored in application folder.
but when I run the exe as administrator it works fine..
so i could see two ways to get it right..
1) give write permissions over the database to the user..
2) olways by default run exe as admin
but I dont know how to do it..
any help would be appreciated...
thanx!

2
Contributors
3
Replies
4
Views
6 Years
Discussion Span
Last Post by Momerath
0

m using win7.. nd yes i installed in prog files..
and now the problem is solved.. but i still dont know how..
as i did number of things.. but i still wanna know the proper solution..

0

Windows 7 doesn't want you to install stuff to the Program Files directory, it automatically makes everything in there read only. Put the software there, but you put the data files in Users/<you> somewhere.

This has been a 'rule' since windows 2000, but Vista and Windows 7 actually started enforcing this by using the read only flag.

Edited by Momerath: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.