marathon 0 Newbie Poster

My new Dell Latitude runs Windows 7 Professional. I previously worked under Win XP Pro. The previous (XP) machine was used as the development platform for a website, which mined a database using Perl scripts. I need to recreate this functionality on the new machine, but it appears that Perl is not behaving. Here’s what I have done:

• Installed Internet Information Service (IIS) 7.
• Copied website and all contents from the old machine to new machine, placing them in the same location as before under Inetpub. This includes .html pages, data source (Microsoft Access Database (.mdb) file) and Perl scripts. I have redirected the Physical Path under my Default Web Site to the root directory for this content.
• Created a new virtual directory called “cgi” under my Default Web Site, and have pointed it to the directory containing the Perl scripts.
• Added a pointer under ODBC to my Microsoft Access Database (.mdb) file.
• Installed the current version (5.12.4) of ActivePerl for my 32 bit machine.

I am able to access the website in my browser as expected under “localhost.” The startup page includes choices for different types of database searches. Choosing one of these should launch a Perl script that generates a new page with special database searching capabilities (pulldown menus, text boxes, Boolean logic, etc.). However, the new page does not appear. Instead, I receive this error message:

“HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.”

So, I am guessing that my problem is due to a missing handler, but this is outside of my actual area of expertise. When installing Active Perl, I did not uncheck any of the default options. I thought that would have covered the addition of any necessary handlers.

Perhaps related: Under Windows XP, you could launch IIS and then right-click on the Default Web Site to get its permissions. That capability has changed under IIS 7. I have been unable to locate a place to set “Execute permissions” to “Scripts and executables.”

I have spent much time searching for a solution, but I think it’s time to turn to the community of experts. Any suggestions would be greatly appreciated!

Jeff

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.