hi, i'm very new to python. i downloaded pyserial on win7 64bit. using Dell N5010 (it doesn't really have serial port) i tried to open port with ser = serial.Serial(0) but it gave error that [Error 2] The system cannot find the file specified. but with ser = serial.Serial(3) and upto 5 system waits for sometime and times out.why??
on ser = serial.Serial(5) and ser = serial.Serial(6) it again comes to input as command executed successfully. what i miss? how come system can open COM port 6,7 if it doesn't have any serial port???:-O

Recommended Answers

Try serial.Serial("COM3") or the port you need.

Jump to Post

All 2 Replies

Try serial.Serial("COM3") or the port you need.

Try serial.Serial("COM3") or the port you need.

ok i got it all done. now i can send data to my 8051 microcontroller using ser.write(25) but it sends junk. i also tried ser.write('A'.encode('ascii')) but again its junk that 8051 receive. my controller works fine with hyper terminal means no problem at 8051's end. any idea of junk???:(

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.21 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.