Hello everyone.

I have the following issue:
I have a Windows XP computer with excel 2003 installed. we use several automation robots using excel. everything works fine, files area created and all that. but we have a problem. for some reason the document recovery pane of excel is getting filled with excel files. we tried to trace the folder where those files are getting stored. usually they are named temp.xls, but with no success.

i was wondering if there is a way to permanently stop that on all workbooks or if there is a way using visual basic scrtip to stop that.

I attached an image where the red square is what I am trying to disable.

thanks in advance

Attachments pantalla.png 8.63 KB

Wouldn't closing the files that your macros use properly be the correct course of action here?

Anyway, I think the command you are looking for is:

application.AutoRecover.Enabled = False

thanks for the reply. i already tried that but is selecting the option above the red square in the picture, not the one that is in the red square.

another sugestions??

Wouldn't closing the files that your macros use properly be the correct course of action here?

Anyway, I think the command you are looking for is:

application.AutoRecover.Enabled = False

In Excel 2007 it's

ActiveWorkbook.EnableAutoRecover = False

and it will only work for the current workbook.

If it doesn't work in 2003 then record a new macro and while recording go in options and change the option you want. Click OK and stop the macro record. The new macro will show you the correct command.

In Excel 2007 it's

ActiveWorkbook.EnableAutoRecover = False

and it will only work for the current workbook.

If it doesn't work in 2003 then record a new macro and while recording go in options and change the option you want. Click OK and stop the macro record. The new macro will show you the correct command.

Thanks for your help, i tried what you said and it worked.

this has been solved

This question has already been answered. Start a new discussion instead.