so i had bought a new graphics card and new powersupply for a pc tower my friend gave me. When I upgraded them both on my computer tower, i pluggged it in and now it wont start at all. Not even the fans turn on. The power button blinks like 3 times and then never does it again until i unplug it for a bit and then plug it back in. Ive been trying to fix it for months but nothings has worked. I have 8gb ram gtx 1050 ti amd 6300 6 core proccessor and 500watt power supply

Member Avatar
Member Avatar
+0 forum 2

I recently replaced the motherboard, wifi card, and switch on my Dell XPS12. Now when powered up, it will shut down on its own within a few minutes. What to check / replace next?

Member Avatar
Member Avatar
+0 forum 2

So I basically tried to make a gaming pc, first one. And I encountered a big problem. I thought I had everything set up and connected (with the disappointment that my Gigabyte Z370 Ultra Gaming didn’t support RGB) but when I went to turn it on for a final test, the motherboard flickered a little of the led it has and just did nothing at all. I pressed the power button then the fans came on and a red light came on on the motherboard. But it continuously turned off and on by itself within the span of like 10 …

Member Avatar
Member Avatar
+0 forum 2

I need a recomendation for a good motherboard and accompianing CPU. Here's what I'm looking for. Compatible with Linux plenty of USB ports plenty of sata ports, may be a dual boot Linux/Windows/SteamOS Although I don't currently do a lot of high end gaming, or gaming at all, but I would like the option to do so if I get the urge. Thanks.

Member Avatar
Member Avatar
+0 forum 1

I have a 7 years old laptop in better condition but there is a problem with their mouse. Mouse does not work properly. after 2 times restarting the system then mouse works but after few time approx. 10 to 20 min or when right clicking then mouse stop working.

Member Avatar
Member Avatar
+0 forum 2

I am looking to buy a motherboard and I'm looking for lots of USB and sata ports, it should fit in this case -> item# N82E16811146077 on newegg.com and will work well with Linux for my main desktop, and a windows and SeamOS drives as well for gaming? Will this motherboard be decent for gaming should the urge take me? Any concerns with Linux? And will it not take an AMD processor? Thanks all. Motherboard -> item# N82E16813132835R on newegg.com Thanks for the help.

Member Avatar
Member Avatar
+0 forum 4

Used two different tvs, one has hdmi and rgb in, and the other has pc in (vga?) and hdmi, use two different cables and nothing. I have not used the pc in with audio yet (a double sided vga cable with audio for monitor), was wondering if I even need that type of cable. I used hdmi to hdmi and hdmi to dvi for the two cables. I just got the motherboard replaced (for not working in the first place) and I haven't installed anything yet, because need the obvious to do so. Read it could be motherboard again; hope …

Member Avatar
Member Avatar
+0 forum 6

Hello, I have had this PC I built myself for almost a year now (probably a little more than a year, I lost count. Lol). LITERALLY this morning I was on it messing around with a friend, then just a moment ago I tried installing a some case LED lights. I turned off the PC via the switch on the power supply before doing so just to be safe. After following the instructions carefully, I turned the PC back on to test the lights, then the front fan's light and power light started blinking. The fans came on each time …

Member Avatar
Member Avatar
+0 forum 4

Help. I have problem with my mobo, it can fully charge the battery but it doesn't turn on. Thanks. Specs: MSI Wind U123x netbook MS-N033 motherboard intel Atom N280 Intel Media Accelerator 945 Integrated chipset 2 GB Kingston RAM

Member Avatar
Member Avatar
+0 forum 2

I need it for gaming n as cheap as it goes..

Member Avatar
Member Avatar
-1 forum 1

Hello everyone, I have a Sony lv-240J and I it turns on all the fans spin but then there is no beep, no boot, no display or anything. After a couple of minutes it just turns off. I connected a display to it and nothing. I tried to use it as a display, it gets read but nothing on the screen. It has been like this for 5 years and I just bought a new motherboard and still no results. I tried a new hard drive with windows on it, still nothing. One ram stick and without ram still nothing. …

Member Avatar
Member Avatar
+0 forum 12

HELP!!! No beep on my motherboard when i remove the RAM & HDD, i tried another RAM & HDD from another computer but still not working. I checked the RAM & HDD if its working on another, it works, i replace the wires(SATA especially) but nothing change,i also replace the PSU. still no Display. Help, i don't know whats the problem anymore, everything is working fine, it is MOTHERBOARD already??What should i do Next??

Member Avatar
Member Avatar
+0 forum 3

Hi all, As the subject line (plea for help!) says, my brand new Corsair RM550x power supply will not power up when there are any peripherals connected to it. Not even just one! However, when it is connected to just the ATX and CPU on the motherboard, I get a blue power light and the fans all start spinning. As soon as I connect even one peripheral, no matter which one, it will not power up. This is for an HTPC, so I can't imagine 550W is not enough for three hard drives, a blu-ray player, and a sata controller. …

Member Avatar
Member Avatar
+0 forum 2

Hello, I have a Abit-AN-M2HD mother board, with a Athlon 64x2 processor, I have the exact same motherboard up and running that I am using now.. I installed cpu fan, power supply is working fine, have reset cmos through pin and battery, have back fan and front fan both running fine, used both radon pciex card and nvidia getting no post and no signal to monitor, have tried onboard still no monitor, all fans, hard drive, DVD drives, lights come on work, fan on video cards turns everything seems to work except for no signal to monitor.. I am at …

Member Avatar
Member Avatar
+0 forum 2

my second article regarding my mac and windows. these problems only started when I got windows 10. my mac was insleep mode and was charging and...well...I was sleeping... I got up cuz I heard a loud humming noise and realized it was my computer. it was really hot. I carefully picked it up and lifted the lid. logged in. AND NOTHING WAS OPEN!?? I opened task manager and nothing was needing that much power from my cpu/gpu the fan kept on going until I shut it down why did this happen ? thanks.

Member Avatar
Member Avatar
+0 forum 3

Repairing the particular hardware is not seen much I expect inspite of repacing it so ,I had came up with a simple idea of assuming with the damaged motherboard caused by electric circuit ... Hope every one deal with it ?

Member Avatar
Member Avatar
+0 forum 1

A couple days ago, my notebook keyboard suddenly stopped responding to ANY input at all. Tried pressing every key and combination I could see, but no reaction. The mouse was working and the PC showed no other strange behaviour. I pressed the power button to put it to sleep, and then woke it up. The keyboard worked fine. This problem kept repeating and became increasingly frequent over the span of a few days. Now it's reached the stage where only a full restart will fix the problem, and that doesn't work every time. I took the whole system apart and …

Member Avatar
Member Avatar
+0 forum 2

hi i hope someone will be readin this and resolve my problem. i own a toshiba satellite c650 laptop. its front cover and hinges were broken so i plucked up some courage to repair it myself. i got the required parts and watched some youtube video tutorial to disassemblt the machine. The laptop was otherwise working fine. However after reassembling i connected the video connecting wire on to the motherboard. when i switched on the power it would not turn on. the fan would not spin. etc. so i took the wire off and retried powering it on. it would …

Member Avatar
Member Avatar
+0 forum 5

I am searching for a wireless adapter to install in my PC as I will be moving it soon and a wired connection is not possible. I am looking at an expansion card I can insert in motherboard as I don't want a USB one. The adapter i'm looking at is PCI-E(x1) and the free slots I have on my motherboard are a PCI-E(x16) which would run at x8 as i have a GPU in the 1st x16 slot and a x4 slot. My question is if i install the x1 wireless adapter in my x4 slot will it affect …

Member Avatar
Member Avatar
+0 forum 1

My brothers laptop recently died, I believe due to a failed hard drive because when you turned it on you couldn't get out of the BIOS. I unscrewed the laptop's bottom from it's keyboard and replaced the hard drive but now it won't even turn on at all, I can't even get a BIOS screen. The only thing that I could visibly see that went wrong when I opened it was two ribbon cables came undone. One was very skinny and the other was wider and they went from the mother board to right under the laptop finger pad. I …

Member Avatar
Member Avatar
+0 forum 8

Hello! I recently aquired a small form factor emachines system and transplanted the motherboard to a somewhat custom case to use it as a htpc. I installed a phenon x4 9550 in it and removed the shitty small original cooler and proprietary backplate and mounted a lga775 cooler to cool the new chip. The board works fine with the chip installed, with the caveat that only a single core seems to be running on the processor. the boards model number is dao61/087l. any help would be greatly appreciated!

Member Avatar
Member Avatar
+0 forum 3

I need some help in deciding which mobo/cpu to choose. My requirements are: 1) Preferable Intel CPU (4 cores) which should be able to address 64GB RAM. 2) 64 GB RAM onboard (4 slots -> 16 GB DIMM ?) 3) Support for USB 2.0 and USB 3.0 (and maybe 3.1 as well) 4) HDMI/DVI onboard 5) 6 or more SATA3 or better connections 6) ATX form factor And of course at an affordable price... (I live in Norway).. I'm not into gaming or video editing, but I want to be able to run some virtual machines along with my host …

Member Avatar
Member Avatar
+0 forum 1

hello i recently build a new pc connecting all the parts and the cables when i turn it on the screen start freezing and only solutions was to either press the reset or the power on/off button, so i went into some research about it and couple of posts in other forums and i've been told that i should run a bench test with only the basics components of the pc to see what cause the freezing, thing is i stripped it down to basics and when i tried to turn it on it wont turn on i start connecting …

Member Avatar
Member Avatar
+0 forum 1

My cpu doesnt work too, when i press the on button it flashes blue light and a click noise and stops and it blinks again with the noise even I'm not pressing it. Tried everything but doesn't work. Please i need help! Med student here... Ive already tried: 1. Blower technique 2. Removing my CMOS and turn it back 3. Changing power cord Please help me!

Member Avatar
Member Avatar
+0 forum 1

So I developed an application for an arduino uno that uses an IteadStudio Joystick Shield with 7 buttons and a joystick with an x/y movement tracker. The 7 buttons are connected to pins 3 through 9, and the joystick is connected to analog inputs 0 and 1, with 0 being the Y and 1 being the X. When I test the buttons, it works correctly. However, if I test the Analog inputs with the code below, the Serial monitor goes completely crazy, producing tons of random ascii characters and those letters with the dots above them. It produces these so …

Member Avatar
Member Avatar
+0 forum 2

I'm planning to set up my own private virtualization server at home with the following hardware setup: Motherboard: MSI X99S SLI PLUS, Socket-2011-3 CPU: Intel Core i7-5820K, Socket-LGA2011-3 Memory: Max 128 GB DDR4 RAM (starting with 32 or 64 GB RAM) PSU: Cooler Master G550M, 550W PSU Server box: Cooler Master CM Force 500 Midi Tower and some sort of water cooling system... :-) I want to run the following OS-es: - Linux Mint 17 - Windows 10 - Windows 7 - Windows 8.1 - Ubuntu 14.04 - and others... :-) On my home office desktop I want to have …

Member Avatar
Member Avatar
+0 forum 4

My Toshiba L770 Satellite Laptop does not power up, no LEDs lit when power adapter is plugged in. Power adapter producing 19.4 volts. Opened up laptop and got 19.4 volts at end of power connector harness when not connected to motherboard and approx 0.5 volts at connector pins on motherboard when adapter is connected. Visual inspection of motherboard showed no obvious problems. Battery doesn't have any affect, whether installed or removed. Also removed BIOS battery for 30 seconds and reinstalled. Still no sign of life from laptop. Does this sound like a bad motherboard? Thanks, LPM

Member Avatar
Member Avatar
+0 forum 2

Hi, Does this old motherboard of my friend supports Pixel Shader version 3.0 and Vertex Shader version 3.0. The Board is:**Intel 946GZ Express Chipset Family** Reply as soon as possible. Thanks,uxama

Member Avatar
Member Avatar
+0 forum 2

Hi, i'm trying to build a display screen headphone similar in shape to "vizio's LCD headphones" shown at CES 2010, but different in function. The display screens on the headphones i want to make have only one function: to show what music the user is listening to. For example if i am listening to a Michael Jackson song, the display screen will be able to show: the name of the song, name of the artists or the album art of the song i'm listening to. My question is about the design of the motherboard. It will need to house a …

Member Avatar
+0 forum 0

Hello everyone, I have this serious issue from a couple of days with my desktop. I bought a new corsair vs350 PSU, since my older psu burst. Then it was working fine but just after two days it crashed and did not startup. I checked each of the plugs and tighten them but nothing works. I can see the green light turning on while giving the power supply. Amazing thing is that my cpu sometimes run successfully when I press the power button after few days. But that is all luck based. I don't understand what can be the problem. …

Member Avatar
Member Avatar
+0 forum 3

The End.