Start New Discussion within our DaniWeb Community Feedback Community

By a strange (and fortunate) coincidence, while DanaWeb was down for the upgrade I had to completely rebuiild my system due to a hard drive failure (fortunately I had warning so I had complete backups). However, I've noticed some odd behaviour since then that I don't know is the result of the DaniWeb rebuild or mine. It used to be that when I clicked the login control (via FireFox 11.0) I was presented with a login dialog prefilled with my username and password. I assumed this was stored in a cookie on my machine. Now I am always presented with a blank form in which I must (oh, the horror) type the fields every time. I have the same add-ons that I had before (Ghostery, Better Privacy, NoScript and Cookie Monster) with excepetions granted for DaniWeb. I have allowed cookies and I even tried with global scripts allowed on NoScript. Can you tell me how this data is persisted so that I can determine the problem?

You could also try to clear the browsers cache. Then you should get to "bake" a new cookie.

Bake a new cookie LOLOL

A DaniWeb cookie does not prefill your username and password in for you. In fact, we would have no way of filling in the password field because we do not store your password in plain text in a cookie on your machine.

As James #2 mentioned, this is a browser setting on your side.

Found the setting. When I did the rebuild and installed all outstanding updpates, FireFox 11 got put in (I was previously at 10). For some reason it decided to make private browsing the default. By turning this off I was able to get back the auto-fill on the login fields.

I'm surprised you didn't realize that private browsing was enabled all this time. It affects all your search history, etc.

We all have our blind spots. Like you said, the answer was in front of me but I just didn't see it. It's fixed now thanks to the suggestions. With luck I'll be more observant in the future.

Ya thread is solved. But I logged in daniweb using mobile browser and even after clearing cache/cookie etc. I get form filled with my ID and password and strange thing is even after clicking on login I dnt get logged in. And It happened only with daniweb and now I am unable to log in from mobile.

Ya thats true I am using UC browser and unable to login, And it only happened with daniweb. Login information is there even after clearing all privacy data, cookies, cache. But I cant login.

:D k but it only happens with ur website but its ok you cant work on every exception. I will use PC.

If the problem was on our side, then either you wouldn't be redirected at all, you'd get a form processing error, or you would be redirected to the login error page. If the page refreshes after you click login, that means that our app confirmed you entered the valid login information and sent the cookie information to your browser.

Its browser issue but it for the first time. Now i dnt save login records n it works fine. [Posted from mobile :) ]

This question has already been answered. Start a new discussion instead.