I've noticed that there are various icons around the site that aren't appearing for me in Firefox the way they appear in Internet Explorer. They seem to be characters without the font needed to render them. I have attached a screenshot that shows the effect, most obviously next to the "Start New Discussion" button and the "Launch Chat Room" button, but also next to the post ages along the right side.

I poked around the web looking for clues and found this: Font Awesome Doesn’t Work In Firefox : Fixed

Unfortunately it doesn't tell me how I can fix this problem, but it makes me think that I might not be the only one having the problem, so I thought it best to bring it to everyone's attention. (Am I the only one still using Firefox? It seems that Chrome doesn't have this problem.)


You might of not read all the way down the page. He has a solution towards the bottom regarding changes to htaccess.

I have scanned Google search pages for more than an hour to find the perfect solution. But finally got my answer from maxcdn official support page.

Actually I did notice that which is why I was quite hopeful when making that post that it was only a brief temporary problem, but after giving it some time I guess that fix doesn't work for this website for some reason.

Perhaps there's some way to fix it on my end. That won't automatically fix it for everyone else who visits this site, but if I figure out a way I will be sure to post it for everyone.

I use Chrome, and I had a problem earlier tonight where the icons worked on first page view, but not if I hit the refresh button. Now, out of no where, they're working. I'm using the version of FontAwesome hosted on their CDN.

Works fine for me from Firefox 24 right now, too.

I'm heading to sleep now, but I'll upgrade Firefox tomorrow and see if I start having issues. As of now, I'm not able to reproduce anything strange going on.

Just upgraded to 26, and still not seeing any issues. :(

I made the suggested .htaccess change. Does it work now for you?? I am seeing nothing wrong in FF, IE or Chrome so I can't reproduce this.

I'm surprised that didn't fix the issue. Google supplied plentiful results that seemed to explain the problem, but it turns out that they were all misleading me. The culprit on my end wasn't Firefox; it was NoScript, even though NoScript claimed to not be blocking anything. I still trust NoScript better than the unrestrained web.

I was able to make Font Awesome work by disabling NoScript, but then I re-enabled it and got Font Awesome working by manually white-listing "bootstrapcnd.com". NoScript wasn't listing it as a blocked site, so I had to type it in myself, but when I did Font Awesome immediately started working.

Member Avatar

Add-ons often mess up my view on sites. When I have an issue now, I start disabling them as my first response (after clearing the cache of course).

I went ahead and removed the .htaccess "fix" that I added before because, it appears, it wasn't much of a fix for anything in the first place.