0

Hey guys!!
Can somebody help me... I cannot setup a glut project in codeblocks under ubuntu , it says

The path you entered seems valid, but the wizard can't locate the include directory.
This wizard cannot continue.

-_-

2
Contributors
5
Replies
61
Views
4 Years
Discussion Span
Last Post by JasonHippy
1

It sounds like you don't have the glut development packages (headers and libraries) installed.
I think installing the freeglut3 and freeglut3-dev packages via apt-get will probably do the trick.
I have a strong feeling that they will depend on several other opengl dev packages, so apt should download and install any additional opengl libraries that aren't already present on your system.

So if you open up a terminal/command line and use the command:
sudo apt-get install freeglut3 freeglut3-dev
That should install all of the necessary development files. You might also want to add a version of glew (The openGL extension wrangler) too:
sudo apt-get install libglew1.6 libglew1.6-dev glew-utils

Once that's done you should have all you need. The next time you run CodeBlocks, you should be able to create a new glut project using the project wizard and with any luck, it should also compile and run without any problems!

0

Yep i know that but still not working, when i start codeblocks => glut project and bla bla and then:

Please select the location of GLUT on your computer.

This is the top-level folder where GLUT was installed (unpacked). To help you, this folder must contain the subfolders include and lib

Please select GLUT's location:

and that's /usr right?

and then the error shows up (the one i've posted in my previous message) :(

0

Have you tried /usr/ (note the additional / at the end.
Otherwise it might be /usr/share
I'll fire up one of my Linux machines in a bit and take a look. (out of my house and on my phone ATM)

very strange, I don't remember C:B ever asking for the location of glut when I've used the wizard for a glut application.....

0

Ah, I see the problem!
I've just fired up Codeblocks on a fresh install of Ubuntu 12.04, added build-essential, Codeblocks and all of the OpenGL development packages and tried to create a glut project from the CodeBlocks template and got the error you mentioned.... Very odd. Not seen that before!

I've got to the bottom of the problem though.
/usr/ is definitely the correct path to use. The wizard assumes that the glut header file will be in the /include subdirectory and the library will be in the /lib directory of the location.
From doing a quick file-search of my system, I can see that glut.h is in /usr/include. But the lib file is in /usr/lib/i386-linux-gnu/.
So the wizard is failing because it cannot find the library files. For some reason they are in a subdirectory of /usr/lib/ rather than in /usr/lib/ itself.

The simplest way to fix it is to create some symbolic links in /usr/lib/ which point to the items in /usr/lib/i386-linux-gnu/
So open a terminal and navigate into /usr/lib/i386-linux-gnu/ and run an ls command to see what files are in there:

cd /usr/lib/i386-linux-gnu
ls ./libglut*

For each item listed, create a corresponding symbolic link in /usr/lib/
NOTE: When I did this, I found the following files: libglut.a, libglut.so, libglut.so3 and libglut.so.3.9.0

To create a link for each file, I did this:

sudo ln --symbolic ./libglut.a ../libglut.a
sudo ln --symbolic ./libglut.so ../libglut.so
sudo ln --symbolic ./libglut.so.3 ../libglut.so.3
sudo ln --symbolic ./libglut.so.3.9.0 ../libglut.so.3.9.0

Depending on which version of Ubuntu you have installed, you might have different versions of files installed than me. The above code works for me. You need to ensure that your symboic links match the names of the glut files on your machine!

Once you've got the symbolic links in place; the next time you run the glut project wizard in CodeBlocks you can specify /usr/ as the location of glut and the wizard will now be able to find the headers and the libraries and will create your project.

For some reason it looks like the installation directory for the glut library files has changed at some point.. Not sure when this happened or why, but there ya go! Not sure who the bug should be reported to either. It could be the package maintainers for glut who are to blame for changing the location where the library is installed to. Otherwise, it could be up to the Code::blocks team to update the wizard for glut projects.... IDK!

Either way, creating symbolic links in /usr/lib/ is probably the best way to fix the problem for now!

Edited by JasonHippy

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.