0

Hello ...

I have a very annoying problem just now, MySQL server in my office is not stable. This morning it has stopped for more than 10 times. :'(
FYI, the version of MySQL is 3.23.54 running on redhad 9.
When I tried to restart it, it showed like this:

=============
[root@servergs etc]# /etc/init.d/mysqld restart
Stopping MySQL: [FAILED]
Starting MySQL: [ OK ]
[root@servergs etc]# /etc/init.d/mysqld restart
Stopping MySQL: [ OK ]
Starting MySQL: [ OK ]
[root@servergs etc]# /etc/init.d/mysqld restart
Stopping MySQL: [ OK ]
Starting MySQL: [ OK ]
[root@servergs etc]# /etc/init.d/mysqld restart
Stopping MySQL: [FAILED]
Starting MySQL: [ OK ]
[root@servergs etc]#
=============

I tried to check the pc, it seems okay. But when I check MySQL service it showed like above. :(

The question is: Why MySQL server is stopped by itself? It has happened before and when I started the service the problem is solved. But now I have to started it over and over again because it keeps stopped by itself. :S

Thanks before ...

2
Contributors
4
Replies
6
Views
7 Years
Discussion Span
Last Post by agongpor
0

What messages do you get in the error log(s)? The mysql error log file is usually found in the mysql data folder and ends in .err

0

What messages do you get in the error log(s)? The mysql error log file is usually found in the mysql data folder and ends in .err

This is the last log file (FYI, I found it at /var/log/) after I restart mysqld.

100511  8:46:47  /usr/libexec/mysqld: Normal shutdown

100511  8:46:47  /usr/libexec/mysqld: Shutdown Complete

100511 08:46:47  mysqld ended

100511 08:46:47  mysqld started
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
/usr/libexec/mysqld: ready for connections

I try to put the line "skip-innodb" but it seems still not stable because when I try to restart it again it showed the result like my first post above.

Thanks for your help.

0

All what I can find about your version of Mysql on Redhat 9 is here: http://bugs.mysql.com/bug.php?id=868

Have you considered to upgrade to a never version? Might solve your problems.

Yes, maybe it is the real problem. I will try it, insyaALLOH.
Thanks for your big help.

(btw, is daniweb has a face-off? it's nice, salute for admins)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.