0

I try in psql shell

pg_dump --schema-only

but is is doing nothing

after hitting enter it just shows glab->

why is that?
I tried adding ';' at the end of line - still the same.

But before it there is glab=> so one char differs. Why is that?

also is thera some way to save the login to database when connecting via shell?

Edited by McLaren

2
Contributors
2
Replies
4
Views
4 Years
Discussion Span
Last Post by McLaren
0

@SPeed_FANat1c

postgre - how to make schema copy

So you want to copy your database by using this pg_dump?

It's more than that.

Read this:

http://www.thegeekstuff.com/2009/01/how-to-backup-and-restore-postgres-database-using-pg_dump-and-psql/

or this:

http://www.cyberciti.biz/tips/howto-backup-postgresql-databases.html

Both of the link I provided give you an example how to create the procedure to create a backup of a database.

Unless you are doing something else then explain what are you trying to do?

Edited by LastMitch: grammer

0

thanks. I took a quickl look, but did not find difference except file name added after command, tried that out but did not do anything as well. So maybe I misslloked.

But for now I don't need that.

The problem was - the hard disk was full of the server and I could not use my application, so I wanted to make a copy of those tables in my local computer so I could work with my application. The progrtammer should had rights to delete files in the server was not here, but he now has deleted. So all ok at least for now :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.