0

hello

So i have problem in connecting to my oracle database on the server it threw an exception like this
"The type initializer for 'Oracle.DataAccess.Client.OracleParameter' threw an exception".
my supervisor told me that it might be a referencing problem in this library Oracle.DataAccess.Client.OracleParameter,but i think that the library doesnt fing my client ,i downloaded the ODAC more than one time and the same exception pops up! ,but the error goes without authentication script in the web.config file.But the authentication is imoprtant and it must not be removed!

<authentication mode="Forms">
      <forms loginUrl="WebForms/ICensus/login.aspx" name="ASPXFORMSAUTH" protection="All"/>
    </authentication>
    <authorization>

does anyone have an idea of how to solve this ?
thank you

1
Contributor
1
Reply
13
Views
3 Years
Discussion Span
Last Post by fedaa91
0

ok since no replied i just want to say that i solved the problem , by downloading the oracle client again and moved the TNS file to the directory of the client and it worked

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.