0

Hi. I'm starting to use clientdatasets after years with Zeos DBO and I'm facing some difficulties. I created a TSQLConnection, a TSqlDataset as a ctTable, a TDatasetProvider and a TClientdataset. I populated the clientdataset and tried an ApplyUpdates(0) to insert the records. But I'm getting a "cannot modify a read-only dataset' message. Updates with sqlconnection.executedirect work perfectly. Changing the TSqlDataset to a TSqlTable didn't help.

I'm using Delphi 2007 Professional with MySQL 4.1.9.

Any ideas?

TIA.

1
Contributor
2
Replies
3
Views
9 Years
Discussion Span
Last Post by ecostas
0

An additional note is that I used a connection to an Interbase file with the same result (cannot modify a read-only dataset). The query only considers one table and I have administrator's privileges, both in MySQL and Interbase. Must be something really simple but I haven't found it yet.

0

Problem solved. Stupid me. I set ResolvetoDataset in the TDatasetProvider to true. 3 weeks of desperation for nothing. Well, knowledge is always welcome and hard earned knowledge is harder to be forgotten.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.