Start New Discussion within our Software Development Community

Aight, so I know I just posted a few hours ago but I promise that after this bug I'll not posted for a couple of days... or weeks.

Aight, so I have two classes -> Connection, and SocketServer (which is inside of "socket.h" and "socket.cpp").

Inside of Connection.cpp, the code "sSocket(myPort, 1, BlockingSocket);" (which initializes sSocket), gives me this s error...

error C2064: term does not evaluate to a function taking 3 arguments c:\Users\Ben\Desktop\Documents\Visual Studio 2008\Projects\ConnectionDLL2\ConnectionDLL2\Connection.cpp 12

Connection.cpp #includes "socket.h" and same with Connection.h. The weird thing is that I don't get this problem if I run it in debugger mode, but I do get the problem when I run it in release mode. I need to run this program in release mode because I'm using openGL and, for some reason, it won't allow me to run it in debugger mode.

I tried using a forward declaration for SocketServer, but that still didn't work.

What's really odd is that Connection.cpp successfully compiles and runs SocketServer's functions, but it wont compile and run its constructors.

One last thing; the Connection.h file's intellisense lets me see SocketServer's constructors but Connection.cpp's intellisense will not.

Thank You,

~Ben S.

Oops, the last paragraph is wrong. Connection.h's intellisense does not let me see SocketServer's constructors just as Connection.cpp doesn't.

The problem of not being able to use the constructor still remains however...


Thanks,

~Ben S.

This article has been dead for over six months. Start a new discussion instead.