0

Hi ,
I am using openRTSP test program. In the make file i used debugg option.
But when i tried to debugg for example : "b 320", i got the following error.
No line 24 in file "init.c".
I don't know about this error. But gdb is working fine.
For debugging i used " -g included files(both header and library) " inside the makefile.
thanks

2
Contributors
4
Replies
5
Views
9 Years
Discussion Span
Last Post by RenjithVR
0

Actually there is no such file named init.c in the directory. I think it may be one of the file related to gdb. I compiled my file using the option -g. And run by gdb executablefilename. then i mentioned the line number as break 320. Now i got that error. I don't know about the init.c file and the location too.

0

Sorry about my first post. I wasn't awake apparently.

Does a simple hello-world program compiled with option '-g' load in GDB?
If yes: Could you post your gcc 'line' (example: gcc -g main.c)

0

I used the following method to debug

g++ -g test.cpp -o test

If i use g++ test.cpp -o test then try to use break point i got the same error. But using the above methode it could working fine.
But Live555 is a library I created a makefile and a test file and wrote this for debugging.

#for debugging
debug:  testRTSP.cpp 
    g++ -g $< ${IDIR} -o $@ ${LIBD} -lBasicUsageEnvironment -lUsageEnvironment -lgroupsock -lliveMedia

It created the executable file aND WORKING FINE.
But here i don't sure whether this do the debugging.
Regards,

Edited by mike_2000_17: Fixed formatting

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.