0

Hi All -

Unfortunately I don't have code to paste for you, but I'm hoping perhaps someone will be able to narrow my focus a bit on this one...

I developed a windows forms app that has a very strong data dependency. When deployed, it works as expected if the user has admin rights to the PC. If, however, it's a non-admin user, the connection to the database never happens and the app crashes.

I've tried deploying both through ClickOnce and a true Setup and Deployment project, and both have the same result. This has to be a permission issue - but I'm not sure where (app or PC - or both). That's where I need some assistance.

So - based on this very loose explanation, do any ideas come to mind?

Thanks in advance for your help!
Tim

2
Contributors
5
Replies
6
Views
9 Years
Discussion Span
Last Post by dickersonka
0

It's a SQL Server database. Thanks for your help!

0

There will most likely be two permissions issues then.
There will be a permission to be allowed to connect to the database. Especially if you use integrated security.
The other will be the permission to use the connector, which most likely is fine if you use the .net one.
Try connecting in sql server management studio with that user and you'll most likely see the same results and appropriate troubleshooting message.

0

Thanks! That gives me plenty to try - and make a ton of sense.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.