Start New Discussion within our Software Development Community

Couldn't find a search button so I'll ask:

I'm running Freebsd v7.0 with the ratpoison window manager, and have installed free pascal from ports. I've been trying for hours to get either Lazarus or fpc-ide installed with no luck.

Lazarus - gives message like menubar>>environment.>environment options>> etc etc etc. If I click Ignore, it comes up showing some source code, and I haven't a clue what to do next.

fpc-ide - cannot install either from ports or pkg_add. It mostly complains something about firefox
or firebird then quits with error code 1. Sometimes it did get to a screen where I can apparently accept or cancel, but nothing happens and it again ends with an error.

I have googled and read the documentation on the fpc site. Does anyone know what's going on here.

Problem solved. I tried, once more, to install fpc-ide as a package, and this time got the message that it was already installed. This despite previous attempts where I got error codes. Looking in /usr/local/bin where fpc resides, I saw a file "fp" which does start fpc-ide.

This question has already been answered. Start a new discussion instead.