Attempting to run java app from zip file rather than jar but having some difficulty. I have placed all the classes for the app in the zip. The files not are compressed. Here's a sample of the code:

'the following tries to run Main.class. Also, tried calling app name
cvm.exe" -Xbootclasspath/a:"\Storage Card\database\jsr169.jar" -Djava.class.path="\Storage Card\Myclasses.zip" Main  

'Error rec'v
java.lang.NoClassDefFoundError: Main (wrong name: MyApp/Main)

any help is appreciated.

Try "MyApp.Main" instead of just "Main". It looks like Main is in a package called MyApp.


thx for reply. it's appreciared. i've tried what you suggested and I ended up w/ the same error.

Myapp is the name of the app.

any help is appreciated.


I think I may have the error. I placed the classes in a folder named "myapp" before zipping and that appears to have done it.

thx again.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.