0

I have got xampp-linux-1.6.7 and xampp-linux-devel-1.6.8a installed on Ubuntu 8.10. I am trying to install mod_wsgi-2.3 and was able to sucesfully run ./configure on it. But when I run make, it gave me a bunch of errors. I am pasting a snipped of it here.

mod_wsgi.c:3886: error: expected ‘;’ before ‘ap_log_error’
mod_wsgi.c:3891: error: expected ‘;’ before ‘}’ token
mod_wsgi.c:3900: error: expected ‘;’ before ‘ap_log_error’
mod_wsgi.c:3904: error: expected ‘;’ before ‘}’ token
mod_wsgi.c:3906: error: expected expression before ‘module’
mod_wsgi.c:3910: error: expected ‘;’ before ‘ap_log_error’
mod_wsgi.c:3914: error: expected ‘;’ before ‘}’ token
mod_wsgi.c:3929: error: expected identifier or ‘(’ before ‘=’ token
mod_wsgi.c:3931: error: expected expression before ‘module’
mod_wsgi.c:3932: error: ‘modules’ undeclared (first use in this function)
mod_wsgi.c:3935: error: expected identifier or ‘(’ before ‘=’ token
mod_wsgi.c:3937: error: expected expression before ‘module’
mod_wsgi.c:3944: error: expected identifier or ‘(’ before ‘=’ token
mod_wsgi.c:3946: error: expected expression before ‘module’
mod_wsgi.c:3950: error: expected ‘;’ before ‘ap_log_error’
mod_wsgi.c:3954: error: expected ‘;’ before ‘}’ token
mod_wsgi.c:3961: error: expected expression before ‘module’
mod_wsgi.c:3965: error: expected expression before ‘module’
mod_wsgi.c:3978: error: expected identifier or ‘(’ before ‘=’ token
mod_wsgi.c:3981: error: expected identifier or ‘(’ before ‘=’ token
mod_wsgi.c:3983: error: expected expression before ‘module’
mod_wsgi.c:3987: error: expected identifier or ‘(’ before ‘=’ token
mod_wsgi.c:3989: error: expected expression before ‘module’

There are literally a few hundreds of this. I tried to get this into a text file by running : make > error.log But I just got a few lines in there. So how do I find about what is going on? Thanks.

1
Contributor
1
Reply
2
Views
8 Years
Discussion Span
Last Post by friendklay
0

Just posting the solution to my error above. The header files required by modwsgi.c were not present in the default python installation of Ubuntu 8.10. Luckily xampp installation had a seperate python runtime, and I was able to pass that with --with-python=/opt/lampp/bin/python.
Now all is well, and modwsgi is configured on my server.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.