I how do i fix this error [Build Error] [main.o] Error 1

The installation of the current beta isn't as good as it should be, at the moment.
You must uninstall all past versions, to be safe, you must use the default {drive}:\Dev-Cpp\ (at least on the XP installations, I've noted), make sure it's not dir Dev-C++ like from the older versions; on Vista make sure you have full admin privileges to install(maybe even to compile).

edit:
And note: It's in beta, so you may find a minor inconveniences, here-and-there.

The installation of the current beta isn't as good as it should be, at the moment.
You must uninstall all past versions, to be safe, you must use the default {drive}:\Dev-Cpp\ (at least on the XP installations, I've noted), make sure it's not dir Dev-C++ like from the older versions; on Vista make sure you have full admin privileges to install(maybe even to compile).

edit:
And note: It's in beta, so you may find a minor inconveniences, here-and-there.

I never have such problems, i've install Dev just about everywhere including onto pen drives. Also Vista doesn't require admin to run or anything like that. I simpley thing he didn't install the compiler only the IDE

This question has already been answered. Start a new discussion instead.