HI

For Christmas I got a book on game programming with allegro. I went through the process of setting up the files and ran, compiled, and linked the program only to find that depending on which compiler I used (Dev-C++ or VC++ 2008) it came up with different errors saying that it couldn't find a certain DLL.

If anyone has experience with this could you let me know a solution.
I am on Windows Vista.

Thanks in advance.

Well in VC++ right click the References in the Solution Explorer to Add Reference then browse for the MSVCR80.dll

I finally found and downloaded the proper file. It seemed to work OK but now I get the error:

The application failed to initialize properly (0xc0000142). Click OK to terminate the application.
[OK]
I found stuff about it online but nothing directly addressed the issue on how to fix it. I just need a strait forward answer, not a way to fix it that is going to need to be fixed itself.

This question has already been answered. Start a new discussion instead.