Pardon my newbness, I only just found this site today and I have been having this problem for a bit.

Background:
I am using Python 2.5.2 that I recieved from a CD from my college. My OS is Windows XP, and my internet provider is Internet Explorer.

Problem:
When I first downloaded and tried to open the IDLE, I was asked - outside of the window as an alert - if I wanted to grant it access to the internet. Not being sure, I denied it. When I try to run a prorgam - or even when I try to open Shell, it gives me an error stating that it "can't bind TCP/IP port 8833" etc, etc.

Is this problem originating from me denying it access, or something else? And what do I do to fix this?

Usually this is fixed pretty easily. Shut down all IDLE's open, and any other programs that could be using python. Then you proceed to the task manager (CTRL+ALT+DEL) and go to the processes tab.

End any processes that have python.exe or pythonw.exe

Once that is all done, try restarting IDLE

Hope that helps

The problem is that you denied IDLE the right to create a loopback server (which it needs; it doens't actually connect to the internet). You need to create an exception in your firewall that allows python to act as a server.

You can google search on how to configure your particular firewall (if you don't have a specific firewall installed, then your firewall might be Windows firewall).

What specifically am I adding to the exceptions list? It seems to be just the Windows firewall, and when I go to add a program to the list, the three I can choose from (python, pythonw, and the w9xpopen) do nothing to allow the Shell to run.

Maybe it would be easiest to uninstall and re-install Python. Perhaps you should look at adopting a new IDE as well (I'm sorry I just can't stand IDLE!)

Just search this website, we have loads of threads on the pros and cons of many other IDE's and im with Jlm. IDLE isnt good enough when programs get complicated. Its best to try something else.

Never mind, I was looking at the wrong firewall (d'oh). It works now, thanks for the help.

Do other IDE's use the same language? And when does IDLE stop being useful?

Never really. It's really a matter of personal preference. If you do actually grow out of IDLE, then you would have matured in Python enough to choose which editor suits you best (and use it well!). Still I find that IDLE never quite stops being useful (especially the interactive interpreter).

Also, almost everytime now I try to run a program, it will give me the error: "Socket error: Connection refused" and not work. I noticed that this happens at my college a lot as well. Is it just the connection having problems?

Yeah i used to get that a lot with IDLE. I did the same thing i outlined above and that fixes that problem for me. Hopefully it works for someone else as well!

This question has already been answered. Start a new discussion instead.