0

How did you disable the Unicode, I used the same program and get the same errors, I tried to disable the Unicode by going to the properties of the program, and unticked the inheritance, but I still get the errors?

4
Contributors
4
Replies
5
Views
9 Years
Discussion Span
Last Post by Nick Evan
0

You didn't mention the compiler you are using, but assuming it is VC++ 2008 (Express)

Select menu item Project --> Properties --> expand Configuration Properties --> General. In the pane on the right, the third item from the bottom, change "Character Set" option to "Not Set"

0

It has no sense at all to disable UNICODE !!
It's the standard !
Windows itself is UNICODE (see Kernel or User source code..)

0

It has no sense at all to disable UNICODE !!
It's the standard !
Windows itself is UNICODE (see Kernel or User source code..)

C++ language has no provisions for UNICODE, and Windows isn't the only os in the world.

Yes, standard ascii strings can be used in UNICODE enabled program, but don't try to pass them to most win32 api functions because it will not work.

1

And quite frankly, I have found UNICODE to be a pain in the behind, so if I don't have a need for it (which is the case in 99.9% of my programs), I won't use it :)

Votes + Comments
Exactly :)
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.