I have some code which "requires python 2.5.2 or bytecode compatible." Would 2.5.4 work? 2.6.2?

Any harm in installing either of these on the same machine as 3.1 (separate directories)? Windows XP if that matters.

I have Python2.5.4 and Python3.1 working on the same XP machine.
Programming editors (IDE) like IDLE may have to be convinced with batch file to use the correct Python version.

Here is example:

REM batch file to force IDLE to run with Python 3.1
REM save as IDLE31.bat
C:\Python31\Pythonw.exe -u C:\Python31\Lib\idlelib\idle.pyw

One similar batch file needs to be created for Python25.

On Windows the version installed last will be the default version. Just in case you double click on a Python script file.

Some IDE editors like Editra allow you to quickly select the Python version you want to apply to your code (use the Launch plugin).

Thanks. Two versions seem to coexist happily and reinstalling 3.1 after 2.5.4 made it the default.

2.5.4 is byte code compatible with 2.5.2. 2.6.2 is not.

This question has already been answered. Start a new discussion instead.