I'm trying to set up NetBeans IDE on my Vista Home, and have a choice between those two compilers. Which one would you choose? I also want to have Code::Blocks.

Hello,
In my opinion you can install MinGW and install Eclipse, but if you want to use NetBeans or other IDE you need to have MinGW.

I had already installed cygwin, but based on your recommendations I deleted it and installed Code::Blocks with MiniGW. Code::Blocks appears to be working now. Then I tried to configure NetBeans to work with the MiniGW that's in Code::Blocks directory. The problem now is that there is no make.exe in that directory. So being the smart ass that I am I downloaded GNU Make for Windows, configured NetBeans to use that program. Apparently that version of make doesn't like the makefiles that NetBeans generates because it produced some sort of error.

make: *** [.validate-impl] Error 255

Anyone have a solution to this problem? Or know why a make.exe program was not installed with MiniGW?

There is a make.exe in the msys directory which is installed alongside the mingw directory.

That's where I found a make.exe anyway, though I'm not clear on what the installation steps were to get it.

There are differences in the make between POSIX and Windows, as well as some problems with the MSYS make (which is POSIX, AFAIK).

You should be using your ~MinGW\bin\mingw32-make.exe program when compiling in the non-POSIX (Windows native) environment, and the ~MSYS\...\bin\make.exe program when compiling under the MSYS POSIX environment.

Hope this helps.

Netbeans does require the "make.exe" from MSYS! It's not possible to use the make from the MinGW ("mingw32-make.exe"). If you have renamed the file "mingw32-make.exe" to "make.exe" then u'll get the error "... make: *** [.validate-impl] Error 255 ..."

Use insteed the make from the directory

=>[MinGW]\msys\1.0\bin\make.exe

If the "make.exe" is not this directory then reinstall MinGW with the MSYS option and correct your path in your Netbeans configuration.

This article has been dead for over six months. Start a new discussion instead.