i get an exception when i am trying to save an xml document. the interesting thing about this problem is i dont get it when i deploy the pocket pc application using visual studio. when i create my smart cab project and run this in pocket pc, the same application gives this exception. all the deployed files are the same, there seems to be nothing missing.

any intuition? any existantialism?

So if you use Visual Studio to run the app on the pocket PC you do not get an error? But if you build an installer you do get an error?

Yeah i solved the problem. i noticed that when you deploy the application visual studio change the file attributes before copying to the device. if there is any read only file it removes that attribute. so it is a good idea to add a file to your set up project from the release folder(when you build, nomatter what attribute your file has it is stripped out of them in the output folder)
Basically you can not save read only xml document as you cant delete it too.

woohoo, a free solved thread! Thanks Serkan :)

is this the only one? you owe me so many solved threads :)

This question has already been answered. Start a new discussion instead.