Hello friends,
I've tried to install wxwidgets in my mandriva 2009 spring for GUI interaction with python. In the installation instruction it said that i need gtk+ library. So i downloaded GTK+. When i configured GTK+ i got the message

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.21.3 atk >= 1.13.0 pango >= 1.20 cairo >= 1.6) were not met:

Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.20.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Then i downloaded glib2.21.3,atk 1.13.0,pango 1.20 and cairo 1.6. I installed all the packages using the following commands.

tar xvzf filename.tar.gz
cd folder
./configure
make
make install

I've not specified any options like --prefix and i installed in the folder itself.
when i tried to install gtk+ after installing all this it showed the same error. What should i do to install wxwidgets? Thanks and regards...

You MUST NOT install packages using source code and "./configure, make, make install". It's the last resort for programs for which no mandriva package exist. The correct way to do it is to install packages with the mandriva software manager. You won't be able to manage the packages yourself.

It's very important that you configure your package sources as I said yesterday to get your packages from the internet.

Also if you need to reinstall your mandriva distro, I suggest that you do it from the mandriva one CD available here (I think that the best version is the gnome version, because the KDE version is slow).

Edited 7 Years Ago by Gribouillis: n/a

Thanks again griboulis for your reply... I've installed wxwidgets successfully.. I've downloaded libwxgtk2.8-devel package using urpmi and installed wxwidgets tarball file as there was no RPM available for i586 architecture..
Thanks for your info on 2010.. Anyhow i've no idea of formatting my sys. and installing 2010. Meanwhile i you've tried it tell me how it is. You've said tkinter3 is available with it.. shall we use only the tkinter rpm and install it to solve the problem?
But still i could not make my tkinter to run after updating the software media still the libtcl status is in redcolor.. Could you please tell me how to solve this issue? thanks and regards...

I'm afraid I can't help you more.It seems that you are having a problem with your package sources. Perhaps you could try to configure them with easy urpmi. About the 2010 version, I installed the python3 package, but could not yet install tkinter3 (it does not seem to be in the mirror site yet). Since the system has only been online for a few hours, I think I can expect this problem to be solved soon.
Good luck with Mandriva. It's a very good linux distribution. Since the 2008.1 version, I have almost no problem with it.

Edited 7 Years Ago by Gribouillis: n/a

This article has been dead for over six months. Start a new discussion instead.