0

Hello guys...

I downloaded JDK 6.0 (btw is it the same as JDK 1.6?)
Anyways, when i want to install it a error message pops up during instalation that says:

Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support or package vendor.


So what can i do? I red somewhere that viruses or adware can be a problem. So i ran all my antivirus programs(Avira, Avast, Spybot, Malwarebytes) and after that, the error messages still appears.

I even turnd off my avast On-Access Scanner but doesn´t help either.

My OS is Windows XP.

Hope someone can help me out on this, i already spent so many hours on this problem.

Thank you...

5
Contributors
17
Replies
18
Views
7 Years
Discussion Span
Last Post by aliartos
0

Thanks for the links...
But i´ve been there already and couldn´t get help.
So far this forum is my last change to get it working.

0

I redownloaded it now 3 times and during installing the error comes up again... always at the same spot by around 95%.

But thanks for this suggestion didn´t thought of it.
But sadly didn´t work :-(

0

i installed the link you gave me and it was successful... but when im going to install JDK 1.6 it´s still the same problem.

And im confused now... It says during installing something like JDK 6 update. So is it just an update or ist it the full Installer for the java development kit?

0

You said that my link's installation was successful. So why try to install another jdk?

Also try to open a command prompt and execute this command:
java -version

I got back this:

java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

Edited by javaAddict: n/a

0

I got the same version like you...

Hmm...

Im not yet an expert... so what i have istalled now is the same i tried to install the whole day?

Because from your link it said something about 10mb size and the one i wanted to install got 76,6 MB.

BTW thanks for your help now i got a little hope back...

0

Almost same version like you i mean...

it´s...

Java(TM) SE Runtime Enviroment (Build 1.6.0_18-bo7)
Java HotSpot (TM) Client VM (build 16.0-b13, mixed mode, sharing)

0

Do you have an IDE installed. (JCreator, NetBeans, eclipse) ?
Try compiling and running a small class and see what happens

0

Won´t work...

Got the message: " javac" is wrong spelled or was not able to find.

Im about to give up :-(

0

Well how do you run the command and from what folder? Maybe you are running it from a folder that doesn't see the javac command.
Where have you installed java?

Do you have a similar path like that?
C:\Program Files\Java\jdk1.5.0_17\bin

0

I got actually 2 versions now. Yours and i DL a JDK 5 version...

The one you referd me to is in : C:\Program Files\Java\jre6\bin

And the Jdk 5 version is in : C:\Sun\SDK\jdk\bin

I set the path in my cmd to both to try out a small class but both doesn´t work.
Ex.: set path= C:\Sun\SDK\jdk\bin

My class is also saved under the class name as text file and .java

Don´t know any further :-(

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.