When compiling some working code on Fedora 11, I am getting this error:

/usr/include/c++/4.4.1/cstdarg:56: error: ‘::va_list’ has not been declared

I am using:

[doriad@davedesktop VTK]$ g++ --version
g++ (GCC) 4.4.1 20090725 (Red Hat 4.4.1-2)

Does anyone know what the problem could be?

Thanks,

Dave

Recommended Answers

Most likely GCC is unable to locate <stdarg.h>, just like <stddef.h> in your other thread. Something is wrong/misconfigured/missing with your setup/environment - that's all I can think of.
Have you tried to locate these files on your computer?
Try passing the -v option to GCC so that you get to …

Jump to Post

All 2 Replies

Most likely GCC is unable to locate <stdarg.h>, just like <stddef.h> in your other thread. Something is wrong/misconfigured/missing with your setup/environment - that's all I can think of.
Have you tried to locate these files on your computer?
Try passing the -v option to GCC so that you get to see where it is looking for files.

Awesome! When looking at the output with -v, I found out that the problem was that I had to put:

/usr/lib/gcc/i586-redhat-linux/4.4.1/include/

at the beginning of my CPLUS_INCLUDE_PATH

Seems strange to me that you have to put something form /usr/lib on an INCLUDE path (I was only looking for files inside /usr/include and /usr/local/include) but I guess these files match the version of gcc that is installed or something?

Thanks again,

Dave

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.