I'm using Borland C++ 5.5, I code my programs using Edit, I compile and run my programs using console.
Before, I was using Windows XP and I had no problem using Edit to code, compiling and running my programs
using console.
Also my programs were in D:\My Documents\Borland\Programs and it all worked well
for me even if my programs were not in C:\Borland\BCC55\Bin. Now I'm using
Windows 7 and now I really have problem, I tried to compile my programs using console pointing to the path of my
programs D:\My Documents\Borland\Programs just like when I'm still using XP
but when I compile my program I got this error 'bcc32' is not recognized as an internal or
external command,
operable program or batch file
.
Can you please help me?
Thanks!

jonsca I already set the path after installing Borland. The procedure on the link that you shared is the same as the procedure I used in XP. But still got this error in Windows 7.

Type "path" (no quotes) at the prompt that you are using. Make sure that your bcc directory is actually there. Otherwise you may have to write a batch file that sets these environment variables and run it each time you open up a prompt (you can automate this by creating a shortcut to something like %COMSPEC% /k "C:\Qt\4.4.3\bin\qtvars.bat" (this is an example from a prompt that Qt sets up for compilation).

Finally I figured it out, I made a simple mistake on the path because my Windows 7 is in a partition in my drive D:, I still have my XP. But at first I was confused because I also installed Borland on my XP and this is the first time I made a partition for an OS. After installing Borland on Windows 7, I opened drive D: and found a Borland folder on it which I thought was the one I just installed(on Windows 7), only to find out that the drive D: on my Windows 7 is the drive C: on my Windows XP, and the C: on my Windows 7 is the drive D: on my XP(I hope I’m right on this observation), so the Borland that I installed on Windows 7 was on C:. So to prove my speculations I delete all the Borland folders both on C: and D: and delete all the files that I found( I even use ctrl+F ) to scan for bcc32 files on my system. After restarting my computer I again installed Borland on my Windows 7 and open the drive D: but it wasn’t there, then I opened C: and it was there(so I’m right), then I changed the path which was previously set to ;D:\Borland\BCC55\Bin; changed it to ;C:\Borland\BCC55\Bin;. After that I restart my computer and start compiling my programs and it worked.

Lesson learned, sometimes you should not be afraid to spend more time exploring something new to you even if it took many days for you to come up with a solution, the benefits and gains are yours, not in terms of money but the knowledge that you acquire from the experience.

Thanks for helping guys!

Edited 6 Years Ago by Sorb3t3ro: n/a

This question has already been answered. Start a new discussion instead.