I have just started with MinGW. I tried to compile a simple C program ie., Hello World but came up with the following error

error:no include path in which to search for stdio.h

can anyone help me out with this problem....

Add the MinGW install path to the PATH environment variable.
I suppose you are using Windows for your development.
Then, right click "My Computer" and go to Properties->Advanced->Environment Variables. Add the MinGW installation path by editing the PATH variable.
Ex: Add ";C:\MinGW\bin" at the end of the existing PATH if it is installed at that location.

You can make sure whether it is correctly set by typing "path" command at the command prompt. It will show something like this:

PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\MinGW\bin

Then, go for compiling your program...
Cheers,

I do not have the same compiler, but ...
Each user-configuration (equivalent of Visual Studio .proj project file) has an option to disable the default path. Make sure the equivalent option is set correctly for your compiler.

The message is not complaining that it can't find the file, it is complaining that it has no place to look for it (no include path). For most compilers, the installer puts a default location into the registry.

If your compiler does not have the default set correctly, you might use the -I option on the command line to tell it where to look for include files.

This article has been dead for over six months. Start a new discussion instead.