Hi, I came up with a difficulty that adding the libmapi32.a to the codelite
IDE linker options.

I go menu->settings->build settings->select gnu-g++ in the left tree->switch->

and change the -l to the -lmapi32,

but the problem is the IDE still does not invoke the `-lmapi32`.
I reboot the PC restart the IDE, but still not results.

Any new idea, how should I cope with this problem?
and I'm using Code Lite inside windows XP SP3.

How should I force the linker to use that? :(
should I have to go and edit the makefile manually?


and I used the #pargma comment(linker,"-lmapi32")
and also #pargma comment(lib,"libmapi32.lib")

but still not working.

--Thanks in advance-

Edited 6 Years Ago by NicAx64: n/a

>> I go menu->settings->build settings->select gnu-g++ in the left tree->switch->
>> and change the -l to the -lmapi32

Those are general build settings, shouldn't you rather add the mapi32 library to the current project's configuration? That would be; from the menu, select Workspace / Open active project settings / Linker, then enter mapi32 in the Libraries: field.

That should do it, assuming that you have libmapi32.a in the lib directory.

This question has already been answered. Start a new discussion instead.