I am getting the following error when I try to access my Resource Files in Visual C++ v6

"The file is already open in an editor."

I've tried closing all windows in the IDE and closing the project, even tried logging out and back in.

All to no avail.

A google search turned up only a few ideas, in English, and they didn't work.

I *really* don't want to have to reenter the entire project.

Thanks!

That was a common problem with that compiler and the only fix is to reboot the computer. Unfortunately there is another common problem -- when you try to save a file the IDE thinks the file is already open by anothe program and can't save it. That can resut in complete loss of the program unless you pay attention to the errors and save it as a different file name before closing the IDE.

After some experiementation and talking to other programmers it seemed that I needed to turn off running antivirus programs, such as Norton Antivirus. That, at least solved the prblem on my computer which was running Windows XP. I have not experienced any of those problems with later versions of the compiler/IDE.

This is a good reason why you should upgrade your compiler to VC++ 2010. Version 6.0 is full of bugs.

Edited 6 Years Ago by Ancient Dragon: n/a

Thanks. In my case I created the basic program and then copied the Resource file into the old folder...

I agree that VS6 can be a bit buggy. But, in support of our Marines sometimes you have to support legacy stuff.

I've got 2010 Express loaded up. But, no actual use for it, yet.

(And, they aren't going to buy six copies of 2010 unless they absolutely have to...)

No matter how much hair I pull out over the buggy-ness! :)

Also, we are running WinXP. Unfortunately, it's a government computer and one thing I absolutely can't do is turn off the AV or any other "Security" measure no matter how crippling it is to our productivity.

Which is why I have never gotten a true and complete install of VS6 nor can I install any service packs as they can't find any VS6 products!

Gotta love those paranoid IT security types. :(

Edited 6 Years Ago by SpiritualMadMan: n/a

I uderstand your problems -- I worked for US gov for quite a few years. You mean you have not installed any of the service packs for that compiler (there were 6 of them)???

That is correct.

I have not been able to install *any* Service Packs.


Apparently the closing registry entries are locked down even for a developers account and therefore when the service Packs try to locate those critical registry entries they aren't there and they don't even try to install.

I've moved to a laptop. But, I have to use an approved device to transfer the compiled version back to the NMCI machine to test, because the 3rd party program I am interfacing to requires a net connect for licensing....

Pray For Me!

This question has already been answered. Start a new discussion instead.