0

I am not able to get GDB to start in -tui mode.
My OS is Win XP, here is what i do

START->RUN->cmd(gdb -tui)
gdb:TUI mode is not supported

gdb
GNU gdb 6.8
....
....
.......
This GDB was configured as "i686-pc-mingw32."

I know that GDB supports tui mode from v5. How come i am not able to get it to run in tui mode as i got v6.8?

Edited by Kakashi Hatake: Included some more information

2
Contributors
4
Replies
5
Views
6 Years
Discussion Span
Last Post by Kakashi Hatake
0

I tried but to no avail. How to do i configure it? It says --enable is not a valid option.

EDIT:
Hmm it seems that i need to build GDB with --enable -tui configure. I have no idea how to do that as well :( I was just using the MinGW package that came with Code::Blocks IDE.

Anyone help please :( ?

Edited by Kakashi Hatake: n/a

0

Yeah, sorry I couldn't be of more help. If you are using C::B, you really don't need the text UI as the IDE has built in support for gdb...

0

Ok so i figured. You can't seem to use gdb in tui mode under Windows. Works fine under Linux(ubuntu) though.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.