i am trying to get java SE development kit for my mac book pro (which has snow leopard)
someone told my to download this java on the apple website but it did not work
it just said this:
This update requires Mac OS X 10.4.11 or higher. Mac OS X Tiger only.

this was the link
http://support.apple.com/kb/DL847

can anyone tell me how or which java to download on the apple website?
cuz there are so many of them
and i don't know which one to download