0

I was running a game I wrote in python with pygame on my Mac 10.6 machine and I notice this Warning.
"Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz."

So does anyone know of an effort to update pygame for this or is there a trick I can use.

1
Contributor
1
Reply
2
Views
6 Years
Discussion Span
Last Post by Gh0st93
0

I was running a game I wrote in python with pygame on my Mac 10.6 machine and I notice this Warning.
"Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz."

So does anyone know of an effort to update pygame for this or is there a trick I can use.

Seriously I think we need to fix this problem by Mac OS 10.7 because the way apple is going they will completely remove it. Making Pygame a great library useless on the Mac at least for future 10.7 users.
I don't know if Pygame 2 will fix this problem but as of now the beta of pygame 2 can pretty much only be tried on windows.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.