my os : windows xp sp3
compilers : gcc 4.5(minGW)
IDE : code blocks 10.05

As the title, when I didn't enable the command -std=c++0x
CImg can work with gcc4.5 and code block(after Build Options > Linker Settings > Link libraries > Add and enter gdi32)
Or use this kind of command

g++ -o hello_word.exe hello_word.cpp -O2 -lgdi32

But when I enable the option of the command of code block
(after Build Options->Compiler Flags->Have g++ follow the coming C++ ISO C++0x.... )
I got error message

error: '_fileno' was not declared in this scope

I don't even know how to alter the command after I want to enable -std=c++0x

Thanks a lot

Recommended Answers

Did you clean and rebuild the project? If so, can you paste the code surrounding the error?

Jump to Post

All 2 Replies

Did you clean and rebuild the project? If so, can you paste the code surrounding the error?

I rebuild it already,this is the error message
error: '_fileno' was not declared in this scope
same as the first post since I enabled the -std=c++0xoption at that time

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.