Hey everyone,
Yesterday I wrote a simple Hello World program and saved it as .py. However, when I tried
to run the .py file it didn't have a default program. So, I went to 'Choose Default Program',
found 'python.exe' and clicked it. 'python.exe' did not show up in the 'Choose Default Program'
window, and I have no idea why.

Any ideas as to how I can begin running my .py files again? (I used to program Python but I
took a break for a while. The files worked fine then.)

Thanks in advance,

- WolfShield

You could try to click the button to restore the default association or reinstall the Python, it does not take long. Reinstall also reinstalls the Idle to right click menu.

I don't see the default association button. I'm running Windows Vista, don't know if
that has to do with it.

I've tried uninstalling and reinstalling Python 2.7.1, I've tried cleaning my registry,
and I've tried everything I can think of from right clicking the file.

So, do any of you know of something I might not of thought of?

Thanks for the reply,

- WolfShield

Try putting it in the path manually?

Yep,
I had already tried that. I still come up with the same problem: when I choose 'python.exe'
as the default program it will not show up in the default programs window.

I'll include some pics to show you what I'm talking about.

And in case you were wondering, I've checked the 'Other Programs' tab every time.

- WolfShield

I had something similar happening in Xp. Finally I deleted the type .py from list of types and selected it again from "no association" list. Alternatively you could try to copy paste informations from pyw type.

Update: I just installed ActivePython from ActiveState.com and set the default
program as 'Python3.2.exe' inside my 'Python3.2' folder and it now runs.

Here is the link to the download: http://www.activestate.com/activepython

Once again, thanks for the time spent helping me. It's great to be in a community
that cares. :)

- WolfShield