THE easiest way is to use a connection string and not 'dsn'. also, remember to configure firewall to allow sql server browser as one of exceptions to remote access. about connection strings, i hope you read the link above. hop this helps.

@chibex64: How is the FTP going to help?

Anyway, what is the exact error you get fransiskus?

You may have everything well installed but some times, the Windows Firewall prevents remote access to your computer except such application is on its trusted list. You cannot turn off your system firewall just because you want to grant external users access to one application......thats lame so you can just enable FTP access on the windows firewall.

FTP uses ports 20 & 21 (22 if sftp), MS SQL uses 1433 & 1434. Enabling FTP won't do you any good.
Besides FTP can be blocked by the firewall as well. If there are problems due to firewall, you create a rule to allo specific traffic, you don't disable firewall or start FTP services.
If disabling the firewall is lame, how do you find giving access to your HDD and command prompt?

FTP uses ports 20 & 21 (22 if sftp), MS SQL uses 1433 & 1434. Enabling FTP won't do you any good.
Besides FTP can be blocked by the firewall as well. If there are problems due to firewall, you create a rule to allo specific traffic, you don't disable firewall or start FTP services.
If disabling the firewall is lame, how do you find giving access to your HDD and command prompt?

Stop being hard. I have had same issues that way severally. Its not about the ports. I use a windows 7 PC and it denies access to sql server when you get it installed. For example, a web application that tries to connect to a remote system on your LAN, Windows firewall wont grant the application access to sql server as long as FTP access is not enabled.

This article has been dead for over six months. Start a new discussion instead.