i've recently published an app but i keep getting this error on machines other than mine.

unable to load DLL acbpdf8-64.dll, module cannot be found HRESULT:0x8007007E

I've copied all the dll's into the /bin folder, so i get the debug and release folders, along with all the dll's, but still nothing?.

i've searched online, and did what was needed, but i still get the error.

btw, the error used to be about a abcpdf8-23.dll, but i changed my app to "any cpu" hoping it would fix the issue?

Anyone ever come across this? any fixes that work?

Thanks.

i've got it this far...

i use

"C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bin\GacUtil.exe" -if "C:\Users\walid\Documents\Visual Studio 2010\Projects\iDMS\iDMS\bin\ABCpdf8-64.dll"

in the post-build script section... but upon running it to register the file to the GAC, but it gives me an error:

------ Build started: Project: iDMS, Configuration: Debug x86 ------
  iDMS -> C:\Users\walid\Documents\Visual Studio 2010\Projects\iDMS\iDMS\bin\Debug\iDMS111.exe
  Microsoft (R) .NET Global Assembly Cache Utility.  Version 3.5.30729.1
  Copyright (c) Microsoft Corporation.  All rights reserved.
  
  Failure adding assembly to the cache:   The module was expected to contain an assembly manifest.
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(3717,9): error MSB3073: The command ""C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bin\GacUtil.exe" -if "C:\Users\walid\Documents\Visual Studio 2010\Projects\iDMS\iDMS\bin\ABCpdf8-64.dll"" exited with code 1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I have no idea how to fix it?..
i tried copying directly to windows/system32 but it gave me an access denied issue, so i went back to registering with the gac..

please help with anything if anyone knows about this..

thanks!.

Edited 5 Years Ago by walid86: n/a

Registering with the GAC can cause issues (in that it looks there first, rather than local and if you make changes to the DLL you have to unregister it from the GAC and reregister it).

When you added the DLL to the project, where does the project think it should be? Right click on the DLL in the References list and select Properties. There is a path property. You can also set "Copy Local" to true and it will expect it in the exe directory.

i'm just trying to have some dll's which are unable to be added to the application files to be published or like copied with the app when published.

At the moment, the application is not linked to them, and i cannot add a reference to them, but they are needed for the project to run.

i've done some research, but results are comming up too complicated so i thought it may not be what i need...

IS there a way to say, when you publish, copy this folder with the application or something?..

I got to the stage of the files publishing with the app, but the error is still there...

The error is when the user clicks a button, it throws an unhandled exception.

unable to load DLL "abcpdf8-64.dll" specified module could not be found. exception from HRESULT: 0x800007E.

any work arounds?..

The solution that worked for me was to enable 32 bit processes to run in the website's application pool. After making that change and stoping and restarting the application pool, the PDFs were generating fine. I hope that helps. -Eric Isaacs

This question has already been answered. Start a new discussion instead.