hii
i've java 1.6.0_11......n window 7...whnevr i try to save file in java\jdk1.6.0_11\bin then it gives a msg i.e

you don't have permission to save in this location.contact to administrator to obtain the permision....

so um nt coming to kwon how to take permision from administrator and save my file...
will any1 help me???

i'll vry thnkful........

If you don't have an administrator password then you can't store a file there.
Why do you want to do that? What is the file? Maybe there is somewhere else you can put it.

administrator password???? actuly um making ma project n thts y its mendatory to save file in bin......n um unable 2 save ma login file in bin............

Please reply in English. Who says its mandatory to save the file there? What is the file?

okk extremly sorry for that......actully i am not getting how to set enviornmentle variables or path in window 7 for direct accessing the java file that why i am saving my file in bin......
i have also a link to set the administrator(http://answers.microsoft.com/en-us/windows/forum/windows_7-security/windows-7-cannot-save-files-to-c-even-after-making/938f2b50-b063-475b-8c5e-905d136df2e3) but after clicking Back up Files and directories i didn't get the add option......will you see this link n tell me whether i have to chnage my setting acc to dis or not??????

Login in to administrator account...and try it also you have to set the correct classpath

Is this your problem:
the jre bin folder isn't in my path so I make that my current directory to execute javac etc. That's why I want to put my java source code in the same directory
?

yes.........
and even after setting the enviornment varible javac was not running.....

Exactly what did you set which environment variable to?

after clicking the environment variable i have added a new user variable......but even then no response.......

Exactly what did you set which environment variable to?

thnkuuuuuuuuuuuuuuuuuuu so mch......my problem has been solved...........thnkuuuuuuu once again

Other people may the same problem in future, so can you describe how you solved it, for their benefit? ... and mark this "solved" so people know.

after clicking the environment variable i have set system variable by clicking on
new-set variable name as Path and variable value as c:\Program Files\Java\jdk1.6.0_11\bin; then click on ok then ok then ok.......
now opn commmand promt and write javac....and at last of cammand prompt i've gotten
j<Flag>.......

u have to set your environment variable..to the location of ua bin folder and end the location with a semicolon.. make sure u press ok..other wise it wouldnt work... now got the commonf prompt u can compile and run ua java files

and if we got J<Flag>at last in command prompt it means we are able to use java....

thnkuuuuuuuuuuuuuu mr jamescherrill for helping........

exactly mr. heamnth.....at the time of setting variable value SEMICOLON( ; ) is MANDATORY............