0

Hi at all, this is my first post on this forum, thus i think it's nice whether i introduce myself.
My real name is Nilo Redini, i came from italy (Pisa), i'm 25 years old and i'm a computer engineer.
It's a lot of time that i read this forum finding many usefull answers, so i've decided to join:)
I've a problem when i compile a curl project using netbeans (version 7.0.1) indeed when i try to build a project i receive many errors about curl library.
After few days i've discovered that the errors are due to the fact that netbeans puts the string '-lcurl' in front of the project files.
i.e. g++ -lcurl my_project.cpp
I've also discoveder that putting the string after all, all go well.
The question is: how can i do this automatically using netbeans:)?
In past i've never had problems like that so i don't know what is changed neither how can i fix this behaviour.

3
Contributors
5
Replies
7
Views
5 Years
Discussion Span
Last Post by badnack
0

What compiler do you use on netbeans? The Netbeans itself can be a problem, since it is a Java IDE. I suggest you compile it with VC++ and then link the library to Netbeans.

Edited by sergent: n/a

0

i'm Sorry i forgot, the project is written in c++ and netbeans use g++; the version is 4.6.1.

0

Nobody has an idea about how can i solve this problem? All i need is just put -lcul at the end of the entire string generated by netbeans to compile,however other suggestions are well accepted.

0

Compiler Search Directories:
C:\Program Files (x86)\curl\include

Linker Search Directories:
C:\Program Files (x86)\curl\lib

Compiler Defines:

CURL_STATICLIB

Link Libraries:
curl
rtmp
idn
ssl
ssh2
crypto
z
ws2_32
wldap32
winmm
gdi32


Linker Options:
-static


Now compile your program.. It will not give errors.

0

I had already linked the curl directory but it wasn't works yet. However i've resolved putting -lcurl in libraries (under Linker) section and removing the same string under option in c++ compiler.
I don't know why i never had the need to do this before, but now all works fine.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.