hi,
I installed NetBeans IDE 7.0 but when I tried run it this message keeps on appearing"see no.1."
I tried to uninstall it but an error message also pops-up "no. 2". I tried changing the conf. but it keeps on saying access denied.

please guys I need your help >.<

1 error_message1

error_uninstall2

Edited 4 Years Ago by Ashenvale: to make it more readable

what specifclly should I look for in the environment variables? how do I know if it is correct?

I checked the path, and inside jre6 there is no lib in it. The only thing i found is
bin, core, patchjre and zipper

@_@ I can't find the path for JAVA_HOME. I didn't find it under system

To see what environment variables are currently set, open a command prompt window and enter: set
Here is what I see on my system:


Microsoft Windows XP [Version 5.1.2600]

D:\JavaDevelopment\Testing\ForumQuestions8>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\Norm\Application Data
Classpath=.;D:\JavaDevelopment
CLIENTNAME=Console
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=TIGERDIRECT2
ComSpec=C:\WINDOWS\system32\cmd.exe
DEV_DRIVE=D:
DEV_HOME=D:
DOCS_HOME=C:
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Norm
include=C:\Program Files\Microsoft Visual Studio\VC98\atl\include;C:\Program Fil
es\Microsoft Visual Studio\VC98\mfc\include;C:\Program Files\Microsoft Visual St
udio\VC98\include
JAVA_RUN=D:\JavaDevelopment\runtime
JDK_HOME=D:\Java\jdk1.6.0_02
....
windir=C:\WINDOWS

D:\JavaDevelopment\Testing\ForumQuestions8>

i tried doing what was in this
link
but end up with the same error.

Windows 7

This is what I got after typing set.

CMD1

This is from netbeans.conf

  • ${HOME} will be replaced by JVM user.home system property
    netbeans_default_userdir="${HOME}/.netbeans/7.0"

  • Options used by NetBeans launcher by default, can be overridden by explicit

  • command line switches:
    netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-XX:MaxPermSize=384m -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true"
  • Note that a default -Xmx is selected for you automatically.
  • You can find this value in var/log/messages.log file in your userdir.
  • The automatically selected value can be overridden by specifying -J-Xmx here
  • or on the command line.

  • If you specify the heap size (-Xmx) explicitly, you may also want to enable

  • Concurrent Mark & Sweep garbage collector. In such case add the following
  • options to the netbeans_default_options:
  • -J-XX:+UseConcMarkSweepGC -J-XX:+CMSClassUnloadingEnabled -J-XX:+CMSPermGenSweepingEnabled
  • (see http://wiki.netbeans.org/FaqGCPauses)

  • Default location of JDK, can be overridden by using --jdkhome <dir>:

netbeans_jdkhome="G:\JAVA\jdk1.6.0_26"

  • Additional module clusters, using ${path.separator} (';' on Windows or ':' on Unix):
    *netbeans_extraclusters="/absolute/path/to/cluster1:/absolute/path/to/cluster2"

  • If you have some problems with detect of proxy settings, you may want to enable

  • detect the proxy settings provided by JDK5 or higher.
  • In such case add -J-Djava.net.useSystemProxies=true to the netbeans_default_options.

I don't have a partition named G:\

This article has been dead for over six months. Start a new discussion instead.