Please , help me. I could not find crystal report view control in my toolbox. I am using visual basic 2010. I don't know if I need to add something. Thanks

just right click on your project in solution explorer window and select properties then just change the framework . it works for me in c# . i dont know it works for you in vb or not. or you can also try to add reference ,or just right click on tool box select add choose item then from .net tab select the crystal report viewer. hope this will help you
regards

just right click on your project in solution explorer window and select properties then just change the framework . it works for me in c# . i dont know it works for you in vb or not. or you can also try to add reference ,or just right click on tool box select add choose item then from .net tab select the crystal report viewer. hope this will help you
regards

•̸ŤђαϞĸs for your reply. I have select the crystal report viewer from the .net but yet it is not showing on the toolbox. And when I select show all, it show it but it is grayed out, I cannot drag it on my form. Please help me out. •̸am using visual studio 2010.
ŤђαϞĸs.

in c# this prob occurs when project's framwork is 4.0 framework for client , if we change it with 4.0 framwork then report viewer we can use. try to search how to change the framework of project may this will help you

just right click on your project , select properties then select compile option then select advance compile option then there will a combobox with value .net 4 Client Profile just select .net framework 4 . you will have crystal report viewer for use :)
if this helped you please vote me up :)

Regards

•̸ŤђαϞĸs so much, it works just fine. I really appreciate you. I vote U̶̲̥̅̊ ĩ̷̊ñ.

Just follow the steps:

  1. Open your project
  2. Click on "project" at top menubar.
  3. Then click on 'properties' at bottom at project drop down.
  4. Click on 'Compile' the go to bottom of it and click at 'Advanced Compile Options'
  5. Now ''Advanced Compile setting' will appare; from there under 'Targer Framwork' change (.NET Framework 4 Clint profile) or others to --->> (.NET Framework 4)
  6. Done

Hope fully it will solve your problem.

Best Wishes

1) In project Properties window in the Application tab change the Target Framework from ".Net Framework 4.0 client profile" to ".Net Framework 4.0"
2) Added the CrystalDecisions.Windows. Forms reference to project (in solution explorer right click in Reference folder and choose "Add Reference" --> for newbies such me)
Now you can able to see CrystalReportViewer.To know more check this article
CrystalReportViewer control

This question has already been answered. Start a new discussion instead.