Hello. I'm trying to start making a basic Operating System with Visual Studio Express 2010 C#, and COSMOS.

I started out with all the default code, didn't change one think. I thought that if it was the default code, it should run without any problems, right? Well, that's not the case.

When I try to boot up first-time COSMOS, I get this error.

System.Exception: Plug needed. System.Boolean  System.Runtime.CompilerServices.RuntimeHelpers.Equals(System.Object, System.Object)`
at Cosmos.IL2CPU.ILScanner.ScanMethod(MethodBase aMethod, Boolean aIsPlug)`
at Cosmos.IL2CPU.ILScanner.ScanQueue()
at Cosmos.IL2CPU.ILScanner.Execute(MethodBase aStartMethod)
at Cosmos.Compiler.Builder.Builder.RunEngine(Object aParam)

This is my code that is in my Program.cs file:

using System;
using Cosmos.Compiler.Builder;

namespace myFirstOS
{
    class Program
    {
        #region Cosmos Builder logic
        // Most users wont touch this. This will call the Cosmos Build tool
        [STAThread]
        static void Main(string[] args)
        {
            BuildUI.Run();
        }
        #endregion

        // Main entry point of the kernel
        public static void Init()
        {
            var xBoot = new Cosmos.Sys.Boot();
            xBoot.Execute();
            Console.WriteLine("Welcome! You just booted C# code. Please edit Program.cs to fit your needs");
            while (true)
                ;
        }
    }
}

This can sometimes be solved by just changing the framework to an earlier version like 3. Have you tried this?

This article has been dead for over six months. Start a new discussion instead.