I am encountering some problems in turboC v2.01....whenever I compile a prog. and error says that " the compiler is unable to include the library stdio.h and math.h"
Please help!!

Try reinstalling and follow the instructions.

Or try installing a more modern compiler instead. Great free ones are available.

i think there is no problem in the installation - there is a problem in the directory path specified in the options menu of turboC..only i dont know how to fix it. The file(turboC) alongwith the include file has been installed in C:\windows\desktop\tc so I entered the same ...but it still shows the error - so I just have to fix the path....help will be appreciated.

I know this is an old post, but I wanted to make the comment that this happened to me once and I couldn't fix it until I reinstalled on the default path (C:\TC).

By the way, I second Dave's opinion on running a newer (or less old) version of Turbo C. You can get it free from many websites. The University of Baja California has it on one of their servers, here's the link: http://fcqi.tij.uabc.mx/aplic

Bye.

i think there is no problem in the installation - there is a problem in the directory path specified in the options menu of turboC..only i dont know how to fix it. The file(turboC) alongwith the include file has been installed in C:\windows\desktop\tc so I entered the same ...but it still shows the error - so I just have to fix the path....help will be appreciated.

Set the directory include option to: C:\windows\desktop\tc\include or if you are using class library:
use C:\windows\desktop\tc\include;C:\windows\desktop\tc\classlib\include

This is a simple problem.
U have to specify path to include header files.
Here is the way to do it.
Open ur program window.
click options at the top.
click directories.
In include directories u have to specify path.
suppose ur tc(compiler) folder is in c drive.
then path is: c:\tc\include

suppose ur tc(compiler) is in directory xyz which is in d drive.
then path is: d:\xyz\tc\include

got it?
if not,reply me.

This article has been dead for over six months. Start a new discussion instead.