Hello All,

I have experienced a very strange problem in my application.
When I launch my WPF application, it loads fine with a window and button, upon clicking the button, it launches another form which is also fine but in this second form, when I click some button, it launches a window with a blank screen (yet I am quite sure it has got many controls to show on the screen).
I have already checked DelegateCommand, Events, Methods but still facing the same issue.
I tried deleting some files as suggested by Google in "C:\Windows\ServiceProfiles\LocalService\AppData\Local" as ~FontCache-S-1-5-21-2260904419-1400770398-4175912926-283977.dat, ~FontCache-System.dat, ~FontCache-FontFace.dat but still it doesn't works out for me.
The error I'm getting is in mscorlib.dll and PresentationFramework.dll which is in the .Net Framework and also a wierd error as A first chance exception of type 'System.Reflection.TargetInvocationException' occurred in mscorlib.dll

Edited 2 Years Ago by KM499

An error like that could mean something blew up in the Window constructor for your WPF Form. (Could be a method or child method or child constructor, there's a lot of possibilities)

I would do a debug step through so you can see exactly where in your code it leaves for the framework and then collapses. That's probably the best place to start.

I already did this debugging thing however still unable to resolve the same.

Could anyone please suggest some approach to solve this problem as I am facing this problem for almost 4 weeks and still unable to find an appropriate solution for the same.

Everything's going fine as expected but as debugging stops a white window appears but the user controls do not load in that....I tried the same code in my friend's computer and amazingly, it worked as expected (no white screens), so I thought it might have been a system problem and I formatted my hard disk and again set up the same environment but again facing the same issue.

Try the following steps for White screen issue.
1. Run services.msc
2. Disable Windows Presentation Foundation Font Cache 3.0.0.0 service from the service list
3. Delete the file "C:\Windows\System32\FNTCACHE.DAT"

I did this one too but still the same, looks like I already got the latest version.

When you reinstalled your OS, did you copy the entire source folder to backup? Inside there's an obj directory. Try deleting that folder and rebuilding.

Edited 2 Years Ago by Ketsuekiame

I did not took the old dll's and exe's...I have tried these steps already by deleting these references and rebuilding the solution again but still does not works for me.
The most important thing I want to find before making it look better is what exactly may be causing this problem so that I could identify that culprit and make the solution go ahead :)

Edited 2 Years Ago by KM499

Given that it works elsewhere, just not on your machine, indicates a possible issue with your machine. The graphics drivers perhaps. Unfortunately, beyond this, I'm out of ideas.

That's fine...I will keep on trying though and when I would find a solution, I'll surely post it here too...Thanks a lot for your suggestions and help :)

We had an identical problem with our WPF application, which we run on iEi All-in-One computers. Occasionally, we'd see one on our manufacturing floor that would show a blank white screen when running our app. Turns out, uninstalling and re-installing the video drivers fixed it.

This question has already been answered. Start a new discussion instead.