I really need help with this. I've been using Visual Studio for C++ and Assembly, and I can build my projects with zero errors, but when I try to Debug I get the message: Unable to start program "C:\mypath\Debug\filename.exe" The system cannot find the file specified.

or if I Start Without Debugging, I get the error:
"C:\mypath\Debug\filename.exe" is not recognized as an internal or external command, operable program or batch file."

The path IS where the .exe should be (in the Debug folder), but it's not there. I tried building and running the same project on another computer and it works fine. I've already tried re-installing Visual Studio, and I get the same error. I'm using 64-bit Windows 8 and Microsoft Visual Studio 2013 for Windows Desktop, if that helps. Please provide any suggestions...My professor doesn't even know how to help me, and I need Visual Studio to do assignments for school.

Edited 2 Years Ago by munchlaxxx

Okay, I tried the Release folder and got the same error. I looked in the folder and there's no .exe file.

Edited 2 Years Ago by munchlaxxx

Thank you for the link. But I can't do this step from the video/tutorial:

To do this, left-click the arrow next to "Configuration Properties" and then left-click the arrow next to "C/C++" to expand the lists below them. Then left-click "Code Generation" below this and left-click "Multi-threaded Debug DLL" next to "Runtime Library."

In the version of Visual Studio I'm using, under "Configuration Properties", there is no "C/C++" option (Just "General", "Debugging", and "VC++ Directories". So I'm not sure how to do this step. I guess I'll google how to create an .exe file in Visual Studio Express 2013.

Any other suggestions are appreciated!

Edited 2 Years Ago by munchlaxxx

Hi,
i'm facing the same problem, and the problem is not "path's"
setting or something like

the VS don't create the .exe, but give me a ok, 1 succeeded
then
where are my .exe ??
did you find a solution ?

thank you in advance

Did you compile under release - or under debug mode?
Oh, and could you explain how you are trying to debug?

Edited 1 Year Ago by ddanbe: addition

Right click on the project -> properties -> and in the tab Application, select Output Type: Console Application.
:)

This article has been dead for over six months. Start a new discussion instead.